Can't load rattle package

r

#1

Hello,
I have installed the ‘rattle’ package, but I get an error when I try to load it.
> library(rattle)
Error in dyn.load(file, DLLpath = DLLpath, …) :
unable to load shared object ‘/Library/Frameworks/R.framework/Versions/3.3/Resources/library/RGtk2/libs/RGtk2.so’:
dlopen(/Library/Frameworks/R.framework/Versions/3.3/Resources/library/RGtk2/libs/RGtk2.so, 6): Library not loaded: /Library/Frameworks/GTK+.framework/Versions/2.24.X11/Resources/lib/libgtk-x11-2.0.0.dylib
Referenced from: /Library/Frameworks/R.framework/Versions/3.3/Resources/library/RGtk2/libs/RGtk2.so
Reason: image not found
Need GTK+ ? (Restart R after installing)

1: Install GTK+
2: Do not install GTK+

Now when I try to install GTK+ it just keeps running forever. What should I do to install/load rattle package?


#2

@B.Rabbit

Try installing “RGtk2” first.

This should solve your problem.

Regards,
Neeraj