Facing difficulty while installing sparklyr in RStudio 3.3.1

sparkr
rspark

#1

Hi guys,

I just encountered this warning saying “Warning in install.packages :
package ‘sparklyr’ is not available (as a binary package for R version 3.1.3)”. Cannot install Sparklyr in R studio. I need sparklyr so as to install rsparkling over it. since, sparklyr is the required dependency, this doesn’t work for me. Need help asap on this please. Thanks in advance.


#2

HI @Ankitdev,

Could u share a bit more about your problem, like what OS are you working on, what steps did u follow for installation etc

Regards,


#3

Hi @jalFaizy Sorry for a delayed response. I was really low on bandwidth.

To elaborate the problem a bit more: The OS I am working on is a Windows 7 machine. I tried these steps in order:

“H2O Flow” and “H2O” were already installed in the system. Followed by these steps: -

1. I tried installing “sparklyr” started giving out errors like “sparklyr’ is not available (as a binary package for R version 3.1.3)”

2. Next I tried installing(Sparklyr) via github command. Started to throw same errors.

3. Installed R on another Windows system, tried the same steps, got H2O and sparklyr installed successfully. Finally when I tried installing “rsparkling”, now for some reason this started throwing out the same error “rsparkling’ is not available (as a binary package for R version 3.1.3)”

For a bit detail outline on problem, here is the thing, I want to install Sparkling Water setup which requires me to install “Sparklyr” and “H2O” setups before I install “rsparkling”. To know more about the Sparkling water setup you might wanna have a look at this link : Sparkling Water- H2O

Now I want to get rid of this error generated while installing those packages.

Should you need more information, please get back.

Regards,
Ankit


#4

@Ankitdev, found some things which could help you.

  • Check the version of R installed in your system, sparklyr depends on R (≥ 3.1.2). Similarly check the dependencies of all the things you are trying to install

  • As per their main page,

If you use the RStudio IDE, you should also download the latest preview release of the IDE which includes several enhancements for interacting with Spark.

If none of the above things work for you, try posting it as an issue on their github repository, maybe they could help you.

Regards,