RWeka library loading error

r

#1

Hi,

When i am loading RWeka library, am getting the following error:

Error: package or namespace load failed for ‘RWeka’:
.onLoad failed in loadNamespace() for ‘RWeka’, details:
call: .jnew(“weka.core.WekaPackageManager”)
error: java.lang.UnsupportedClassVersionError: weka/core/WekaPackageManager (Unsupported major.minor version 52.0)

Can anyone guide???


#2

Hi ankush,
You should try with a newer version of Java. This looks like a version issue.
Ankit


#3

Hi Ankit,

Thanks for your quick response. It will be much helpful if you kindly share the link from where I can download that.

Thanks & Regards,
Ankush


#4

What ankit2106 tried to say you is that there are several versions of Java out there. Recently, I had a similar problem because I was using by default the OpenJDK 7 package but changing it to OpenJDK 8 and updating the paths (something related to the javareconf), solved my problems. Check the versions of your Java installation (how is the process depends on your OS).


#5

I am not aware of java, infact i dont have any java installed!! plz share the path from where i can download?


#6

It depends on your OS! For instance, I’m on archlinux, so, I install it by using:

sudo pacman -S jre8-openjdk-headless jre8-openjdk jdk8-openjdk openjdk8-doc openjdk8-src

but we don’t know what OS are you using. Obviously, you always can check the Java page: https://www.java.com/.


#7

Vate,

i am using Windows 8, 64 bit