Unable to update conda packages behind corporate firewall. Updated .condarc file, proxy settings still it is asking for Proxy user name and password

conda
python

#1

I am behind a corporate firewall. I am trying to update the conda packages by running :

conda update --all

This is aking me for proxy user name and password.

https proxy username:
https proxy username: Password:

After reading many articles on this problems i have taken help from my IT people and updated the proxy_server content in “.condarc” file as follows:

binstar_upload: true
channels:
- https://conda.binstar.org/numba
- https://pypi.python.org/simple/
- defaults
proxy_servers:
    http: http://poPYtheSailor:spinach\@1234@1.1.1.1:5080
    https: https://poPYtheSailor:spinach\@1234@1.1.1.1:5080
ssl_verify: false

Here, proxy server user name and password are my local machine login/password.

After doing all this i am still getting the same message. It is still asking for username and password. According to the IT people “the querry is able to contact to the website from where the package are to be downloaded. But it is not able to contact to the proxy as it is not carrying any user id and password”. I don’t really know what it means. Please help me to solve this issue. We also have apperently dynamic IP adress - though my PC IP address is same for last one year.

Following is “Conda info” command output.

Current conda install:

     platform : win-64
conda version : 3.14.1
conda-build version : 1.14.1
python version : 3.4.3.final.0
requests version : 2.7.0
root environment : C:\Anaconda3  (writable)
default environment : C:\Anaconda3
envs directories : C:\Anaconda3\envs
package cache : C:\Anaconda3\pkgs
 channel URLs : https://conda.binstar.org/numba/win-64/
                https://conda.binstar.org/numba/noarch/
                https://pypi.python.org/simple/win-64/
                https://pypi.python.org/simple/noarch/
                https://repo.continuum.io/pkgs/free/win-64/
                https://repo.continuum.io/pkgs/free/noarch/
                https://repo.continuum.io/pkgs/pro/win-64/
                https://repo.continuum.io/pkgs/pro/noarch/
  config file : C:\Users\poPYtheSailor\.condarc
is foreign system : False

#2

Hi,

You can try to include these proxy setting from the command line in windows machine.

set http_proxy=http://your_proxy:your_port
set http_proxy=http://username:password@your_proxy:your_port
set https_proxy=https://your_proxy:your_port
set https_proxy=https://username:password@your_proxy:your_port

Thanks